Android install button not working

I’m writing this in case anyone else is looking for an answer to this question.

For a long time, at certain times, whenever I tried to install an app on my HTC Desire S, the ‘Install’ button would be greyed out and refuse to work.

I spent ages looking for the answer, typing the question in countless variations into Google when I came across the answer in a forum.

If you have downloaded ‘Screen Filter’, an app which darkens your screen to save the battery and reduce glare in darkened rooms, when activated, somehow the app causes the install button to malfunction.

The fix is simple, just switch off the filter and the install works fine. Screen Filter is a brilliant app so I won’t suggest you uninstall it. Just a simple workaround until the developer fixes it.

Advertisements

, , , , ,

  1. #1 by KIRAN on March 3, 2012 - 03:07

    nice actually more than nice i am facing same problem from 3 months thanks for the post my problem is solved

  2. #2 by theo on March 29, 2012 - 14:21

    Brilliant! thank you for the explanation, it’s been driving me crazy. at one point i even thought it was some kind of a new security trick from google to prevent installation of non-market apps. uninstalled almost everything, except of course the screen filter, which is a very handy app for htc desire bravo. facepalm of shame. cheers

  3. #3 by Sheila on May 18, 2012 - 19:25

    Apparently, it doesn’t have to be just an app that controls brightness. Quick Settings is the only one I have, and I’ve been having the same issue. Just for the heck of it I checked running services and turned off Drawer Launcher, which adds app shortcuts to the notification bar. Voila! can install apk’s again.

  4. #4 by Hilde Teigen on May 26, 2012 - 11:33

    Thanks thanks… The drawer launcher was the problem:-)

  5. #5 by sulieman on July 5, 2012 - 12:37

    excellent!
    I hated my phone since I bought it for that!

  6. #6 by MJ on September 5, 2012 - 04:14

    wooooooooooow thanks so much dear

  7. #7 by kih_oskh on September 11, 2012 - 16:33

    nice solution… was drivin me nuts at bedtym… thanks.. 😉 😉

  8. #8 by Austin on October 29, 2012 - 06:13

    Wow would of never guessed! They really need to fix that. Thanks!

  9. #9 by George Wild on October 30, 2012 - 18:21

    Thank you! In my case it was night mode preventing me from installing apps on my Xperia U.

  10. #10 by Ahmad Sharif on November 15, 2012 - 23:24

    Thank You 🙂

  11. #11 by openmitko on November 28, 2012 - 06:56

    Thank you so much!!!

    It was Screen Adjuster in my case.

  12. #12 by manvi on November 30, 2012 - 08:38

    It really is a random act of brilliance.

  13. #13 by manvi on November 30, 2012 - 08:41

    It really is a random act of brilliance. Looking for a solution for a week now.
    Thank you.

  14. #14 by JB on January 7, 2013 - 08:20

    Thank you, Thank you , Thank you !!!

  15. #15 by Ryan on January 7, 2013 - 17:39

    Thank you!!! This was bothering me for so long and I didn’t know how to get around it!!!

  16. #16 by Konrad on January 14, 2013 - 20:28

    Thanks, this helped me solve a frustrating issue!

  17. #17 by tresila on February 23, 2013 - 16:22

    OMG THANKS SOOOO MUCH!
    you’ve made my day!!!
    i’ve been annoyed by this problem for ages already
    really appreciated your help:D

  18. #18 by mandy on March 21, 2013 - 02:29

    Thanks allot bro it was making me crazy, happy now. God Bless You.

  19. #19 by Timmy on April 17, 2013 - 11:20

    Of course! Thanks =)

  20. #20 by lollapalozzatoni on April 21, 2013 - 13:39

    thanks , this means the world to me…
    i’ve searched in google for ages without solution…
    but the solution is so simple (other pages recommend me to format, etc) …

  21. #21 by John on April 23, 2013 - 21:44

    You’re a legend!! Thanks!
    (It was Screen Filter for me too)

  22. #22 by Nik on June 6, 2013 - 19:04

    Awesome, this solution also works with Twilight

  23. #23 by John Adam Ziolkowski on June 10, 2013 - 16:46

    Thank you! I had a different but similar app named Screen Adjuster running. I had the exact same issue and was losing it. Turning off the adjustment worked perfectly (I did not have to close the app). A pretty weird issue if you ask me, but I am glad you figured it out.

  24. #24 by mukund on October 9, 2013 - 22:40

    Omg..thanks a lot!! I was wondering what is wrong with my phone.

  25. #25 by baran on January 21, 2014 - 19:17

    Thanaaaaaaks so much you really helped me

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: